summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2012-12-24 14:32:23 +0200
committerTor Lillqvist <tml@iki.fi>2012-12-24 21:11:41 +0200
commit4a3018e4eceb981aadbadbe3eadff4c17f018357 (patch)
tree32553bb7e71c50d7f1435f3f36fc672c03ce3bfd /configure.ac
parentFurther Windows SDK cleanups (diff)
downloadcore-4a3018e4eceb981aadbadbe3eadff4c17f018357.tar.gz
core-4a3018e4eceb981aadbadbe3eadff4c17f018357.zip
MSVS 9.0 uses mspdb80.dll, go figure
Change-Id: Id37b276983b86455dcbdcd40fd1e3d3efba33011
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ef4dfef900c5..b0d85b91ba4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3122,8 +3122,15 @@ if test "$_os" = "WINNT"; then
MSPDB_PATH="$VC_PRODUCT_DIR/bin/amd64"
fi
- if test ! -e "$MSPDB_PATH/mspdb${vcnum}.dll"; then
- AC_MSG_ERROR([No mspdb${vcnum}.dll in $MSPDB_PATH, Visual Studio installation broken?])
+ case $vcnum in
+ 90)
+ mspdbnum=80;;
+ *)
+ mspdbnum=$vcnum;;
+ esac
+
+ if test ! -e "$MSPDB_PATH/mspdb${mspdbnum}.dll"; then
+ AC_MSG_ERROR([No mspdb${mspdbnum}.dll in $MSPDB_PATH, Visual Studio installation broken?])
fi
MSPDB_PATH=`cygpath -d "$MSPDB_PATH"`