summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-11-24 17:41:50 +0100
committerStephan Bergmann <sbergman@redhat.com>2018-12-06 23:01:34 +0100
commitd7b46ef1cf69c9fe5c4c36958ca5d5b40de8cf8d (patch)
tree21af0743d7f06165e43d52b4c29fb5cfba60d937 /configure.ac
parentBump (Linux) GCC baseline to 7.0.0 (diff)
downloadcore-d7b46ef1cf69c9fe5c4c36958ca5d5b40de8cf8d.tar.gz
core-d7b46ef1cf69c9fe5c4c36958ca5d5b40de8cf8d.zip
Remove obsolete GCC version checks
...after <https://gerrit.libreoffice.org/63951> "Bump (Linux) GCC baseline to 7.0.0". (In some cases, those checks now need to check for __clang__, which was implicitly covered in the past by Clang consistently reporting to be GCC 4.2.1.) Change-Id: I860fef8c4ca41c22a7541f0fb2d34b37d1d69bed Reviewed-on: https://gerrit.libreoffice.org/63952 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 02114bfd17f9..4e55ddbff76e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6258,13 +6258,13 @@ elif test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
#if defined SYSTEM_LIBCMIS
// See ucb/source/ucp/cmis/auth_provider.hxx:
- #if __GNUC__ >= 7
+ #if !defined __clang__
#pragma GCC diagnostic push
#pragma GCC diagnostic ignored "-Wdeprecated"
#pragma GCC diagnostic ignored "-Wunused-but-set-parameter"
#endif
#include <libcmis/libcmis.hxx>
- #if __GNUC__ >= 7
+ #if !defined __clang__
#pragma GCC diagnostic pop
#endif
#endif