summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatúš Kukan <matus.kukan@collabora.com>2014-03-31 19:36:41 +0200
committerMatúš Kukan <matus.kukan@collabora.com>2014-04-01 11:04:32 +0200
commit8dc394d5c573e5583760c7cc56c5c19062d3f062 (patch)
tree400cf8f6dbf0cfc620df46ef2ddb5d984c4f4abc /configure.ac
parentvcl: FixedHyper - take into account text alignment (diff)
downloadcore-8dc394d5c573e5583760c7cc56c5c19062d3f062.tar.gz
core-8dc394d5c573e5583760c7cc56c5c19062d3f062.zip
Revert "Allow to build lpsolver based on CoinMP library."
This reverts commit 4f7b96886ec2e98f270a9ec3c3509cd523fce7cc. Conflicts: configure.ac scp2/InstallModule_ooo.mk Change-Id: I5621496d70a2c493eb964c1138d310c68fa6d660
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac86
1 files changed, 36 insertions, 50 deletions
diff --git a/configure.ac b/configure.ac
index 07b2d248f04d..f039f1b835e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -654,6 +654,7 @@ linux-android*)
enable_lotuswordpro=no
enable_mpl_subset=yes
enable_opengl=no
+ enable_lpsolve=no
enable_report_builder=no
with_theme="tango"
test_cups=no
@@ -1763,14 +1764,6 @@ AC_ARG_WITH(system-npapi-headers,
[with_system_npapi_headers="$with_system_headers"]
)
-AC_ARG_WITH(lpsolver,
- AS_HELP_STRING([--with-lpsolver],
- [Specify which library to use for lpsolver implementation in sccomp.
- Possible values: "lpsolve", "coinmp", "no". The default value is "lpsolve".
- Example: --with-lpsolver="coinmp"]),
- WITH_LPSOLVER=$withval,
- WITH_LPSOLVER="lpsolve")
-
AC_ARG_WITH(webdav,
AS_HELP_STRING([--with-webdav],
[Specify which library to use for webdav implementation.
@@ -7330,6 +7323,7 @@ if test $_os = iOS; then
enable_mpl_subset=yes
enable_opengl=no
enable_lotuswordpro=no
+ enable_lpsolve=no
enable_postgresql_sdbc=no
enable_lotuswordpro=no
enable_extension_integration=no
@@ -9413,48 +9407,40 @@ AC_SUBST(MYTHES_LIBS)
dnl ===================================================================
dnl How should we build the linear programming solver ?
dnl ===================================================================
-if test "$enable_mpl_subset" = "yes"; then
- WITH_LPSOLVER="coinmp"
+
+# Should we check for system CoinMP ? How to do that ?
+BUILD_TYPE="$BUILD_TYPE COINMP"
+
+ENABLE_LPSOLVE=
+AC_MSG_CHECKING([whether to build with lpsolve])
+if test "$enable_lpsolve" != "no"; then
+ ENABLE_LPSOLVE=TRUE
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_LPSOLVE)
+
+AC_MSG_CHECKING([which lpsolve to use])
+if test "$with_system_lpsolve" = "yes"; then
+ AC_MSG_RESULT([external])
+ SYSTEM_LPSOLVE=TRUE
+ AC_CHECK_HEADER(lpsolve/lp_lib.h, [],
+ [ AC_MSG_ERROR(lpsolve headers not found.)], [])
+ save_LIBS=$LIBS
+ # some systems need this. Like Ubuntu....
+ AC_CHECK_LIB(m, floor)
+ AC_CHECK_LIB(dl, dlopen)
+ AC_CHECK_LIB([lpsolve55], [make_lp], [:],
+ [ AC_MSG_ERROR(lpsolve library not found or too old.)], [])
+ LIBS=$save_LIBS
+ libo_MINGW_CHECK_DLL([lpsolve55])
+else
+ AC_MSG_RESULT([internal])
+ SYSTEM_LPSOLVE=
+ BUILD_TYPE="$BUILD_TYPE LPSOLVE"
fi
-if test $_os = iOS -o $_os = Android; then
- WITH_LPSOLVER="no"
-fi
-AC_MSG_CHECKING([for lpsolver library])
-case "$WITH_LPSOLVER" in
-coinmp)
- AC_MSG_RESULT([CoinMP])
- # Should we check for system CoinMP ? How to do that ?
- BUILD_TYPE="$BUILD_TYPE COINMP"
- ;;
-lpsolve)
- AC_MSG_RESULT([lpsolve])
- AC_MSG_CHECKING([which lpsolve to use])
- if test "$with_system_lpsolve" = "yes"; then
- AC_MSG_RESULT([external])
- SYSTEM_LPSOLVE=TRUE
- AC_CHECK_HEADER(lpsolve/lp_lib.h, [],
- [ AC_MSG_ERROR(lpsolve headers not found.)], [])
- save_LIBS=$LIBS
- # some systems need this. Like Ubuntu....
- AC_CHECK_LIB(m, floor)
- AC_CHECK_LIB(dl, dlopen)
- AC_CHECK_LIB([lpsolve55], [make_lp], [:],
- [ AC_MSG_ERROR(lpsolve library not found or too old.)], [])
- LIBS=$save_LIBS
- libo_MINGW_CHECK_DLL([lpsolve55])
- else
- AC_MSG_RESULT([internal])
- SYSTEM_LPSOLVE=
- BUILD_TYPE="$BUILD_TYPE LPSOLVE"
- fi
- ;;
-*)
- AC_MSG_RESULT([none, disabled])
- WITH_LPSOLVER=""
- ;;
-esac
AC_SUBST(SYSTEM_LPSOLVE)
-AC_SUBST(WITH_LPSOLVER)
dnl ===================================================================
dnl Checking for libexttextcat
@@ -12552,8 +12538,8 @@ if test "$enable_mpl_subset" = "yes"; then
if test "$enable_opengl" != "no" -o "x$ENABLE_OPENGL" = "xTRUE"; then
AC_MSG_ERROR([need to --disable-opengl - GL transitions support.])
fi
- if test "$WITH_LPSOLVER" = "lpsolve"; then
- AC_MSG_ERROR([need --with-lpsolver=coinmp or --without-lpsolver - calc linear programming solver.])
+ if test "$enable_lpsolve" != "no" -o "x$ENABLE_LPSOLVE" = "xTRUE"; then
+ AC_MSG_ERROR([need to --disable-lpsolve - calc linear programming solver.])
fi
MPL_SUBSET="TRUE"