summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKatarina Behrens <Katarina.Behrens@cib.de>2015-06-02 11:13:44 +0200
committerKatarina Behrens <Katarina.Behrens@cib.de>2015-06-03 15:22:11 +0200
commit793db97a7cd4ca93b7106deb95f55e451679b189 (patch)
tree3383b6351837fa06bc3da4c51ede24045a2fc00c /configure.ac
parentSwAddressListDialog::LoadHdl_Impl: simplify (diff)
downloadcore-793db97a7cd4ca93b7106deb95f55e451679b189.tar.gz
core-793db97a7cd4ca93b7106deb95f55e451679b189.zip
Build time option --disable-extension-update
to disable the possibility to update installed extensions Change-Id: Ifdee0f3b13ee3e2bcb288c8ded98cb9805a6e55a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ed3823ebcd64..85bbd222eba7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1318,6 +1318,11 @@ AC_ARG_ENABLE(online-update,
LibreOffice. By default, it is enabled on Windows and Mac, disabled on Linux.]),
,)
+AC_ARG_ENABLE(extension-update,
+ AS_HELP_STRING([--disable-extension-update],
+ [Disable possibility to update installed extensions.]),
+,)
+
AC_ARG_ENABLE(release-build,
AS_HELP_STRING([--enable-release-build],
[Enable release build.
@@ -11738,6 +11743,22 @@ fi
AC_SUBST(ENABLE_ONLINE_UPDATE)
dnl ===================================================================
+dnl Test whether to enable extension update
+dnl ===================================================================
+AC_MSG_CHECKING([whether to enable extension update])
+ENABLE_EXTENSION_UPDATE=
+if test "x$enable_extension_update" = "xno"; then
+ AC_MSG_RESULT([no])
+else
+ AC_MSG_RESULT([yes])
+ ENABLE_EXTENSION_UPDATE="TRUE"
+ AC_DEFINE(ENABLE_EXTENSION_UPDATE)
+ SCPDEFS="$SCPDEFS -DENABLE_EXTENSION_UPDATE"
+fi
+AC_SUBST(ENABLE_EXTENSION_UPDATE)
+
+
+dnl ===================================================================
dnl Test whether to create MSI with LIMITUI=1 (silent install)
dnl ===================================================================
AC_MSG_CHECKING([whether to create MSI with LIMITUI=1 (silent install)])
@@ -12983,6 +13004,7 @@ AC_CONFIG_FILES([config_host.mk
AC_CONFIG_HEADERS([config_host/config_buildid.h])
AC_CONFIG_HEADERS([config_host/config_clang.h])
AC_CONFIG_HEADERS([config_host/config_eot.h])
+AC_CONFIG_HEADERS([config_host/config_extension_update.h])
AC_CONFIG_HEADERS([config_host/config_cairo_canvas.h])
AC_CONFIG_HEADERS([config_host/config_cups.h])
AC_CONFIG_HEADERS([config_host/config_features.h])