summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-04-16 09:56:08 +0300
committerTor Lillqvist <tml@collabora.com>2014-04-16 09:56:08 +0300
commit77be5e9064134fa0b559537433d57b6c0c646fa5 (patch)
tree353fae21e3e12dd40fc468d825875aa941f3f823 /configure.ac
parentWaE: Unreferenced function definition [loplugin:unreffun] (diff)
downloadcore-77be5e9064134fa0b559537433d57b6c0c646fa5.tar.gz
core-77be5e9064134fa0b559537433d57b6c0c646fa5.zip
Update experimental hacks for using Clang from the NDK
Change-Id: Id8fd8ca3c53fe97caa00a2d1c80b73387a4be2bc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cbc7199aad38..05a2931da38f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -223,7 +223,9 @@ AC_ARG_WITH(android-ndk-toolchain-version,
AS_HELP_STRING([--with-android-ndk-toolchain-version],
[Specify which toolchain version to use, of those present in the
Android NDK you are using. Mandatory if the NDK used has several
- toolchain versions for the host architecture you are building for.]), ,)
+ toolchain versions for the host architecture you are building for.
+ Possible values are 4.6, 4.8, clang3.3 and clang3.4. Only 4.8 has been
+ tested for real...]), ,)
AC_ARG_WITH(android-sdk,
AS_HELP_STRING([--with-android-sdk],
@@ -268,12 +270,14 @@ if test -n "$with_android_ndk"; then
ANDROID_BINUTILS_DIR=$ANDROID_NDK_HOME/toolchains/$android_platform_prefix-$with_android_ndk_toolchain_version
ANDROID_COMPILER_DIR=$ANDROID_BINUTILS_DIR
;;
- clang3.1|clang3.2)
+ clang3.3|clang3.4)
AC_MSG_WARN([Building with the Clang tool-chain is known to break in the bridges module, fix that please])
ANDROID_BINUTILS_DIR=$ANDROID_NDK_HOME/toolchains/$android_platform_prefix-4.6
ANDROID_COMPILER_DIR=$ANDROID_NDK_HOME/toolchains/llvm-${with_android_ndk_toolchain_version#clang}
ANDROID_USING_CLANG=true
;;
+ *)
+ AC_MSG_ERROR([Unrecognized value for the --with-android-ndk-toolchain-version option])
esac
if test ! -d $ANDROID_BINUTILS_DIR; then