summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2016-12-14 22:39:02 +0100
committerRene Engelhard <rene@debian.org>2016-12-14 22:39:02 +0100
commit647f149a7413d4b88c5567691909c32ae9449501 (patch)
treecdd5646109657bfe469cf719c031f26cdd988236 /configure.ac
parentwhy can't tde die (diff)
downloadcore-647f149a7413d4b88c5567691909c32ae9449501.tar.gz
core-647f149a7413d4b88c5567691909c32ae9449501.zip
only check for libEGL in internal epoxy case
as that TTBOMK is the case where it's used. At least it's not used in vcl and slideshow directly Change-Id: Ie77656e56e0017800bc0107c2bfe63ddc4b5b9a5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 62cb35eb3ecf..e36dbd41ba1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10106,7 +10106,6 @@ if test "x$enable_gtk3" = "xyes"; then
GTK3_CFLAGS=$(printf '%s' "$GTK3_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
FilterLibs "${GTK3_LIBS}"
GTK3_LIBS="${filteredlibs}"
- AC_CHECK_LIB(EGL, eglMakeCurrent, [:], AC_MSG_ERROR([libEGL required.]))
fi
AC_SUBST(GTK3_LIBS)
AC_SUBST(GTK3_CFLAGS)
@@ -11700,6 +11699,9 @@ dnl ===================================================================
dnl Check for system epoxy
dnl ===================================================================
libo_CHECK_SYSTEM_MODULE([epoxy], [EPOXY], [epoxy >= 1.3.1], ["-I${WORKDIR}/UnpackedTarball/epoxy/include"])
+if test "$with_system_epoxy" = "no"; then
+ AC_CHECK_LIB(EGL, eglMakeCurrent, [:], AC_MSG_ERROR([libEGL required.]))
+fi
dnl ===================================================================
dnl Test whether to use avahi