summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-02-14 10:17:56 +0200
committerTor Lillqvist <tml@iki.fi>2013-02-14 10:31:20 +0200
commitf9890873d448865a268126f8001c25317c3d3bfc (patch)
tree1966c7c22fb2c14cd987f1c30bc7db2e74bde1b0 /configure.ac
parentpyagenda: forgot this file (diff)
downloadcore-f9890873d448865a268126f8001c25317c3d3bfc.tar.gz
core-f9890873d448865a268126f8001c25317c3d3bfc.zip
Build DESKTOP stuff for BUILD only if HOST is of type DESKTOP
The helplinker library has grown a dependency on the svt and tl libraries. But the helpcompiler module is needed to be built for the BUILD platform only if the HOST platform's BUILD_TYPE includes DESKTOP (or only if its BUILD_TYPE includes HELP?). We used to build helpcompiler and some other things for the BUILD platform depending on whether the BUILD platform's BUILD_TYPE included DESKTOP. Also, codemaker should surely be built for BUILD unconditionally, ant xmlhelp presumably not at all. Change-Id: I3df995ce6b92da4ce9eb35115cf3e8560e06f292
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1355f3c0da72..1436110f4900 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12445,6 +12445,10 @@ AC_CONFIG_HEADERS([config_host/config_vclplug.h])
AC_CONFIG_HEADERS([config_host/config_version.h])
AC_OUTPUT
+if test "$CROSS_COMPILING" = YES; then
+ (echo; echo export BUILD_TYPE_FOR_HOST=$BUILD_TYPE) >>config_build.mk
+fi
+
# touch the config timestamp file
if test ! -f config_host.mk.stamp; then
echo > config_host.mk.stamp