summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Foley <pefoley2@verizon.net>2012-12-03 19:04:20 -0500
committerThorsten Behrens <tbehrens@suse.com>2013-02-06 14:04:46 +0100
commitf20af6b8885afa89c276ecbe22754daca63393e7 (patch)
tree56cf515a7ec0366bf4b27b0de120951790255343 /configure.ac
parentsdremote - enable volume control slide-switching by default. (diff)
downloadcore-f20af6b8885afa89c276ecbe22754daca63393e7.tar.gz
core-f20af6b8885afa89c276ecbe22754daca63393e7.zip
use md5 for scp2 stamp
Conflicts: Makefile.top Change-Id: Ib416077c6a866c265f7346df8a86ac7bc254c37d
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 4 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 98aafcba05c1..da60c50c5d90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11821,8 +11821,7 @@ if test "$MD5SUM" = "md5"; then
fi
if test -z "$MD5SUM"; then
- AC_MSG_WARN([no md5sum: found!])
- add_warning "no md5sum: found!"
+ AC_MSG_ERROR([no md5sum: found!])
fi
fi
@@ -12403,11 +12402,9 @@ fi
AC_SUBST(LO_PATH)
-# Generate a configuration timestamp we can use for deps
+# Generate a configuration md5 we can use for deps
if test -f config_host.mk; then
- mv -f config_host.mk config_host.mk.last
-else
- echo > config_host.mk.last
+ config_md5=`$MD5SUM config_host.mk | sed "s/ .*//"`
fi
AC_CONFIG_FILES([config_host.mk Makefile lo.xcent solenv/inc/minor.mk instsetoo_native/util/openoffice.lst])
@@ -12422,7 +12419,7 @@ AC_OUTPUT
# touch the config timestamp file
if test ! -f config_host.mk.stamp; then
echo > config_host.mk.stamp
-elif diff config_host.mk config_host.mk.last >/dev/null 2>&1; then
+elif test "$config_md5" = `$MD5SUM config_host.mk | sed "s/ .*//"`; then
echo "Configuration unchanged - avoiding scp2 stamp update"
else
echo > config_host.mk.stamp