summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-02-01 14:48:15 +0200
committerTor Lillqvist <tml@iki.fi>2013-02-01 14:51:20 +0200
commitebdd616580bb0d367b78ba0fe3fa56157b90c3ab (patch)
tree9db561fa9feb967920ee87eb0194f337a6e6e479 /configure.ac
parentConfigury of OS X code signing and sandboxing (diff)
downloadcore-ebdd616580bb0d367b78ba0fe3fa56157b90c3ab.tar.gz
core-ebdd616580bb0d367b78ba0fe3fa56157b90c3ab.zip
Add option to set bundle identifier and use it when signing
Sign also all the dylibs and frameworks in the bundle. Change-Id: I7f67b9d7eda0204b24e2ea2ef44a53fb8db0f8aa
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7f9fa4ddbca7..2c27d51e7324 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1125,6 +1125,12 @@ AC_ARG_ENABLE(macosx-sandbox,
don't use unless you are working on this.]),
,)
+AC_ARG_WITH(macosx-bundle-identifier,
+ AS_HELP_STRING([--with-macosx-bundle-identifier=tld.mumble.orifice.TheOffice],
+ [Define the OS X bundle identifier. Default is the somewhat weird
+ org.libreoffice.script ("script", huh?).]),
+,with_macosx_bundle_identifier=org.libreoffice.script)
+
AC_ARG_ENABLE(postgresql-sdbc,
AS_HELP_STRING([--disable-postgresql-sdbc],
[Disable the build of the PostgreSQL-SDBC driver.])
@@ -2743,6 +2749,12 @@ if test "$_os" = "Darwin"; then
else
AC_MSG_RESULT([no])
fi
+
+ AC_MSG_CHECKING([what OS X app bundle identifier to use])
+
+ MACOSX_BUNDLE_IDENTIFIER=$with_macosx_bundle_identifier
+
+ AC_MSG_RESULT([$MACOSX_BUNDLE_IDENTIFIER])
fi
AC_SUBST(FRAMEWORKSHOME)
AC_SUBST(MACOSX_SDK_PATH)
@@ -2753,6 +2765,7 @@ AC_SUBST(MAC_OS_X_VERSION_MAX_ALLOWED)
AC_SUBST(XCRUN)
AC_SUBST(MACOSX_CODESIGNING_IDENTITY)
AC_SUBST(ENABLE_MACOSX_SANDBOX)
+AC_SUBST(MACOSX_BUNDLE_IDENTIFIER)
dnl ===================================================================
dnl Windows specific tests and stuff