summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-02-02 12:38:13 +0200
committerTor Lillqvist <tml@iki.fi>2013-02-02 12:38:37 +0200
commite6093cff4776fde16a038fdd1d000ffbfc7b77b1 (patch)
tree56f16d9d3c0ed6805e6e80134bf585de106a778e /configure.ac
parentchop custom target off a11y relation widget target name (diff)
downloadcore-e6093cff4776fde16a038fdd1d000ffbfc7b77b1.tar.gz
core-e6093cff4776fde16a038fdd1d000ffbfc7b77b1.zip
Clarify the different kinds of signing certificates (stackoverflow.com)
Change-Id: Ib0a7e74d394c3c5f7d2f3d7f5ba70bf6a714b604
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2c27d51e7324..2a72b40f574d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2720,9 +2720,13 @@ if test "$_os" = "Darwin"; then
AC_MSG_CHECKING([whether to do code signing])
if test \( -z "$enable_macosx_code_signing" -o "$enable_macosx_code_signing" = yes \) -a $MACOSX_SDK_VERSION -ge 1070; then
- # By default use the first suitable certificate. Not sure if should be looking for the
- # 'Developer ID Application:' ones instead. The code signing stuff could be much better
- # documented...
+ # By default use the first suitable certificate (?).
+
+ # http://stackoverflow.com/questions/13196291/difference-between-mac-developer-and-3rd-party-mac-developer-application
+ # says that the "Mac Developer" certificate is useful just for self-testing. For distribution
+ # outside the Mac App Store, use the "Developer ID Application" one, and for distribution in
+ # the App Store, the "3rd Party Mac Developer" one.
+
identity=`security find-identity -p codesigning -v 2>/dev/null | grep 'Mac Developer:' | awk '{print $2}' |head -1`
if test -n "$identity"; then
MACOSX_CODESIGNING_IDENTITY=$identity