summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Ostrovsky <david@ostrovsky.org>2013-02-11 22:31:52 +0100
committerTor Lillqvist <tml@iki.fi>2013-02-12 08:29:45 +0000
commitc260273f4dfff579d3a3a1132742b46cdb699e70 (patch)
tree59195ed9968f431b0a820763763bd0d794c62659 /configure.ac
parentA missing getuid.so is not fatal (diff)
downloadcore-c260273f4dfff579d3a3a1132742b46cdb699e70.tar.gz
core-c260273f4dfff579d3a3a1132742b46cdb699e70.zip
fix cross compiling with icu 50.1.2
Change-Id: Ib112a2d3f9a75890591137a78b46be982b7d43df Reviewed-on: https://gerrit.libreoffice.org/2112 Reviewed-by: Joren De Cuyper <joren.libreoffice@telenet.be> Reviewed-by: Tor Lillqvist <tml@iki.fi> Tested-by: Tor Lillqvist <tml@iki.fi>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 55e4d739a6b3..c906e0e6c82f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8611,6 +8611,13 @@ You can use --with-system-icu-for-build=force to use it anyway.])
fi
fi
+ if test "$cross_compiling" = "yes"; then
+ if test "$ICU_MAJOR" -ge "50"; then
+ AC_MSG_RESULT([Ignore ICU_MINOR as obviously the libraries don't include the minor version in their names any more])
+ ICU_MINOR=""
+ fi
+ fi
+
libo_MINGW_CHECK_DLL([ICUDATA], [icudata][$ICU_MAJOR][$ICU_MINOR])
libo_MINGW_CHECK_DLL([ICUI18N], [icui18n][$ICU_MAJOR][$ICU_MINOR])
libo_MINGW_CHECK_DLL([ICUUC], [icuuc][$ICU_MAJOR][$ICU_MINOR])