summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2013-02-13 20:21:44 +0100
committerRene Engelhard <rene@debian.org>2013-02-13 20:21:44 +0100
commita45b42b8018834e8b6a1dd54a2ab91b51fbc02a6 (patch)
tree1d29f83bc46c2ba33a3187cef06ce2fdb629c714 /configure.ac
parentlink to java.sun.com/j2se/1.5/docs/api instead of /1.4.1/ in the odk java docs (diff)
downloadcore-a45b42b8018834e8b6a1dd54a2ab91b51fbc02a6.tar.gz
core-a45b42b8018834e8b6a1dd54a2ab91b51fbc02a6.zip
don't use -notimestanp when using gjdoc as javadoc
Change-Id: Ie729aaeaeff41838a435a043dec10c5016355187
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c906e0e6c82f..1355f3c0da72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6354,7 +6354,12 @@ if test "$SOLAR_JAVA" != ""; then
JAVADOC=`cygpath -d "$JAVADOC"`
JAVADOC=`cygpath -u "$JAVADOC"`
fi
+
+ if test `$JAVADOC --version 2>&1 | $GREP -c "gjdoc"` -gt 0; then
+ JAVADOCISGJDOC="yes"
+ fi
fi
+AC_SUBST(JAVADOCISGJDOC)
if test "$SOLAR_JAVA" != ""; then
# check if JAVA_HOME was (maybe incorrectly?) set automatically to /usr