summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-02-05 00:06:03 +0200
committerTor Lillqvist <tml@iki.fi>2013-02-05 01:52:42 +0200
commit6a0017e05c6c8655991732944b7799920bd07222 (patch)
treec96dca989918083bf462fa1fc95058e603492d7e /configure.ac
parentWe want to be able to print (diff)
downloadcore-6a0017e05c6c8655991732944b7799920bd07222.tar.gz
core-6a0017e05c6c8655991732944b7799920bd07222.zip
Use the "Developer ID Application" identity for codesigning by default
Change-Id: I460f18f257323745a068b1685b295b0379615e1b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fd8f10b24649..51b9244cdbe0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2725,9 +2725,10 @@ if test "$_os" = "Darwin"; then
# http://stackoverflow.com/questions/13196291/difference-between-mac-developer-and-3rd-party-mac-developer-application
# says that the "Mac Developer" certificate is useful just for self-testing. For distribution
# outside the Mac App Store, use the "Developer ID Application" one, and for distribution in
- # the App Store, the "3rd Party Mac Developer" one.
+ # the App Store, the "3rd Party Mac Developer" one. I think it works best to the the
+ # "Developer ID Application" one.
- identity=`security find-identity -p codesigning -v 2>/dev/null | grep 'Mac Developer:' | awk '{print $2}' |head -1`
+ identity=`security find-identity -p codesigning -v 2>/dev/null | grep 'Developer ID Application:' | awk '{print $2}' |head -1`
if test -n "$identity"; then
MACOSX_CODESIGNING_IDENTITY=$identity
pretty_name=`security find-identity -p codesigning -v | grep $MACOSX_CODESIGNING_IDENTITY | sed -e 's/^[[^"]]*"//' -e 's/"//'`