summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-02-05 22:45:18 +0200
committerTor Lillqvist <tml@iki.fi>2013-02-05 22:53:52 +0200
commit1651080f8a11cd02d316d661b65c6d4e247d085e (patch)
tree2b3fda325fafc5665788ba6e81afe8053ace0a0d /configure.ac
parentThis is supposed to be sorted (diff)
downloadcore-1651080f8a11cd02d316d661b65c6d4e247d085e.tar.gz
core-1651080f8a11cd02d316d661b65c6d4e247d085e.zip
Add --enable-readonly-installset option
Not yet implemented in the code, but my idea is that any functionality that modifies the system-wide installation will go away in this case. Automatically set if --disable-externsions, or if building a sandboxed LO for OS X. Should probably be set automatically also when just building a signed (but not necesssarily sandboxed) LO for OS X? Surely installing a system-wide extension should count as tampering with the app. Especially if we can make also extension (scripts) be signed (by locating them in the Resources folder?) Change-Id: Id654bfaa6331535a66eae1bc6531a756085a3f06
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b510cac6add3..98aafcba05c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1131,6 +1131,13 @@ AC_ARG_WITH(macosx-bundle-identifier,
org.libreoffice.script ("script", huh?).]),
,with_macosx_bundle_identifier=org.libreoffice.script)
+AC_ARG_ENABLE(readonly-installset,
+ AS_HELP_STRING([--enable-readonly-installset],
+ [Prevents any attempts by LibreOffice to write into its installation. That means
+ at least that no "system-wide" extensions can be added. Experimental work in
+ progress.]),
+,)
+
AC_ARG_ENABLE(postgresql-sdbc,
AS_HELP_STRING([--disable-postgresql-sdbc],
[Disable the build of the PostgreSQL-SDBC driver.])
@@ -2772,6 +2779,20 @@ AC_SUBST(MACOSX_CODESIGNING_IDENTITY)
AC_SUBST(ENABLE_MACOSX_SANDBOX)
AC_SUBST(MACOSX_BUNDLE_IDENTIFIER)
+AC_MSG_CHECKING([whether to treat the installation as read-only])
+
+if test \( -z "$enable_readonly_installset" -a "$ENABLE_MACOSX_SANDBOX" = YES \) -o \
+ "$DISABLE_EXTENSIONS" = TRUE; then
+ enable_readonly_installset=yes
+fi
+if test "$enable_readonly_installset" = yes; then
+ AC_MSG_RESULT([yes])
+ ENABLE_READONLY_INSTALLSET=YES
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_READONLY_INSTALLSET)
+
dnl ===================================================================
dnl Windows specific tests and stuff
dnl ===================================================================