summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@suse.com>2013-04-24 14:52:46 +0100
committerMichael Meeks <michael.meeks@suse.com>2013-04-24 16:21:40 +0100
commitcb33ae88e000fb6c662ecf31a621a73223dfd081 (patch)
tree1a45217a3a461ed2e9d757fe44c15c1bb5a91e8a /configure.ac
parentfix fdo#60910 FILESAVE loses fontwork/shape objects (diff)
downloadcore-cb33ae88e000fb6c662ecf31a621a73223dfd081.tar.gz
core-cb33ae88e000fb6c662ecf31a621a73223dfd081.zip
extend license filtering, and add fallback-checks.
Change-Id: Ia1ec3564326cf898d756c231a64a54db8698bf20
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a002d93642a8..14a721e9a85a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6944,12 +6944,17 @@ AC_MSG_CHECKING([MPL subset])
MPL_SUBSET=
if test "$enable_mpl_subset" = "yes"; then
if test "x$enable_postgresql_sdbc" != "xno"; then
- AC_MSG_ERROR([need to --disable-postgresql-sdbc.])
+ AC_MSG_ERROR([need to --disable-postgresql-sdbc - the postgress database backend.])
fi
if test "$enable_lotuswordpro" = "yes"; then
- AC_MSG_ERROR([need to --disable-lotuswordpro.])
+ AC_MSG_ERROR([need to --disable-lotuswordpro - a Lotus Word Pro file format import filter.])
fi
+ if test "$enable_neon" != "no"; then
+ AC_MSG_ERROR([need to --disable-neon - webdav support.])
+ fi
+
MPL_SUBSET="TRUE"
+ AC_DEFINE(MPL_HAVE_SUBSET)
AC_MSG_RESULT([only])
else
AC_MSG_RESULT([no restrictions])
@@ -11931,6 +11936,7 @@ AC_CONFIG_HEADERS([config_host/config_features.h])
AC_CONFIG_HEADERS([config_host/config_global.h])
AC_CONFIG_HEADERS([config_host/config_graphite.h])
AC_CONFIG_HEADERS([config_host/config_harfbuzz.h])
+AC_CONFIG_HEADERS([config_host/config_lgpl.h])
AC_CONFIG_HEADERS([config_host/config_kde4.h])
AC_CONFIG_HEADERS([config_host/config_mingw.h])
AC_CONFIG_HEADERS([config_host/config_oox.h])