summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-03-10 22:48:20 +0100
committerMichael Stahl <mstahl@redhat.com>2014-03-11 11:57:16 +0100
commitad40015ac4eb17e9b2bd337ec81b745cfede5b5b (patch)
tree63fae35f547c7ba0e2b29e14e80d4b630a80aab6 /configure.ac
parentnormalize values of BUILD_POSTGRESQL_SDBC (diff)
downloadcore-ad40015ac4eb17e9b2bd337ec81b745cfede5b5b.tar.gz
core-ad40015ac4eb17e9b2bd337ec81b745cfede5b5b.zip
normalize values of WITH_GSSAPI/WITH_KRB5
Change-Id: I72c67d5a4987f25ddfa21d93a89b0ceae40c9e81
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index b8a1b8f984f5..b3506f7ac915 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8278,13 +8278,13 @@ if test "x$enable_postgresql_sdbc" != "xno"; then
else
# if/when anything else than PostgreSQL uses Kerberos,
# move this out of `test "x$enable_postgresql_sdbc" != "xno"'
- WITH_KRB5=NO
- WITH_GSSAPI=no
+ WITH_KRB5=
+ WITH_GSSAPI=
case "$_os" in
Darwin)
# MacOS X has system MIT Kerberos 5 since 10.4
if test "$with_krb5" != "no"; then
- WITH_KRB5=YES
+ WITH_KRB5=TRUE
save_LIBS=$LIBS
AC_SEARCH_LIBS(com_err, [com_err 'com_err -lssl -lcrypto' krb5 'krb5 -lcrypto -ldes -lasn1 -lroken'], [],
[AC_MSG_ERROR([could not find function 'com_err' required for Kerberos 5, try installing libcom_err devel package])])
@@ -8296,7 +8296,7 @@ if test "x$enable_postgresql_sdbc" != "xno"; then
LIBS=$save_LIBS
fi
if test "$with_gssapi" != "no"; then
- WITH_GSSAPI=YES
+ WITH_GSSAPI=TRUE
save_LIBS=$LIBS
AC_SEARCH_LIBS(gss_init_sec_context, [gssapi_krb5 gss 'gssapi -lkrb5 -lcrypto'], [],
[AC_MSG_ERROR([could not find function 'gss_init_sec_context' required for GSSAPI])])
@@ -8311,7 +8311,7 @@ if test "x$enable_postgresql_sdbc" != "xno"; then
;;
Linux|GNU|*BSD|DragonFly)
if test "$with_krb5" != "no"; then
- WITH_KRB5=YES
+ WITH_KRB5=TRUE
save_LIBS=$LIBS
AC_SEARCH_LIBS(com_err, [com_err 'com_err -lssl -lcrypto' krb5 'krb5 -lcrypto -ldes -lasn1 -lroken'], [],
[AC_MSG_ERROR([could not find function 'com_err' required for Kerberos 5])])
@@ -8323,7 +8323,7 @@ if test "x$enable_postgresql_sdbc" != "xno"; then
LIBS=$save_LIBS
fi
if test "$with_gssapi" != "no"; then
- WITH_GSSAPI=YES
+ WITH_GSSAPI=TRUE
save_LIBS=$LIBS
AC_SEARCH_LIBS(gss_init_sec_context, [gssapi_krb5 gss 'gssapi -lkrb5 -lcrypto'], [],
[AC_MSG_ERROR([could not find function 'gss_init_sec_context' required for GSSAPI])])
@@ -8333,7 +8333,7 @@ if test "x$enable_postgresql_sdbc" != "xno"; then
;;
*)
if test "$with_krb5" = "yes"; then
- WITH_KRB5=YES
+ WITH_KRB5=TRUE
save_LIBS=$LIBS
AC_SEARCH_LIBS(com_err, [com_err 'com_err -lssl -lcrypto' krb5 'krb5 -lcrypto -ldes -lasn1 -lroken'], [],
[AC_MSG_ERROR([could not find function 'com_err' required for Kerberos 5])])
@@ -8345,7 +8345,7 @@ if test "x$enable_postgresql_sdbc" != "xno"; then
LIBS=$save_LIBS
fi
if test "$with_gssapi" = "yes"; then
- WITH_GSSAPI=YES
+ WITH_GSSAPI=TRUE
save_LIBS=$LIBS
AC_SEARCH_LIBS(gss_init_sec_context, [gssapi_krb5 gss 'gssapi -lkrb5 -lcrypto'], [],
[AC_MSG_ERROR([could not find function 'gss_init_sec_context' required for GSSAPI])])