summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-05-03 14:49:01 +0200
committerStephan Bergmann <sbergman@redhat.com>2018-05-03 21:10:32 +0200
commit0d7baf34ea56d27775f417e07dd854ad3d2fc3b1 (patch)
treed0506f54c4f62019cfa08ecb36f139eca81f9618 /configure.ac
parenttdf#117268: treat erroneous \itap0 the same way as Word does (diff)
downloadcore-0d7baf34ea56d27775f417e07dd854ad3d2fc3b1.tar.gz
core-0d7baf34ea56d27775f417e07dd854ad3d2fc3b1.zip
Remove unused --with-help=common
...see mail thread starting at <https://lists.freedesktop.org/archives/libreoffice/2018-April/080050.html> "Anybody using --with-help=common?". Instead, make configure fail for unknown --with-help=... arguments. Change-Id: I51b8b9087a88ff3a3681453cdc830aa7e499e8df Reviewed-on: https://gerrit.libreoffice.org/53793 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 15cd5bb408c7..eda8f07c0df3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1939,8 +1939,6 @@ AC_ARG_WITH(help,
--without-help no local help (default)
--with-help=html build the new HTML local help
--with-help=online build the new HTML online help
- --with-help=common bundle common files for the local
- help but do not build the whole help
],
,)
@@ -4710,9 +4708,6 @@ if test -n "$with_help" -a "$with_help" != "no" -a $_os != iOS -a $_os != Androi
BUILD_TYPE="$BUILD_TYPE HELP"
GIT_NEEDED_SUBMODULES="helpcontent2 $GIT_NEEDED_SUBMODULES"
case "$with_help" in
- "common")
- AC_MSG_RESULT([common only])
- ;;
"html")
ENABLE_HTMLHELP=TRUE
SCPDEFS="$SCPDEFS -DWITH_HELP"
@@ -4723,10 +4718,13 @@ if test -n "$with_help" -a "$with_help" != "no" -a $_os != iOS -a $_os != Androi
HELP_ONLINE=TRUE
AC_MSG_RESULT([HTML])
;;
- *)
+ yes)
SCPDEFS="$SCPDEFS -DWITH_HELP"
AC_MSG_RESULT([yes])
;;
+ *)
+ AC_MSG_ERROR([Unknown --with-help=$with_help])
+ ;;
esac
else
AC_MSG_RESULT([no])