summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Kaganski <mike.kaganski@collabora.com>2019-05-07 21:22:08 +0300
committerMike Kaganski <mike.kaganski@collabora.com>2019-06-14 01:16:22 +0200
commit58ef8c188b6bb2ed307f5e825cc7e475c33d0c33 (patch)
tree4a6cdec70c156052c8b69728ade5ed37cf0d8b1e /configure.ac
parentDon't link avmediagst with gtk3 and qt5 (diff)
downloadcore-58ef8c188b6bb2ed307f5e825cc7e475c33d0c33.tar.gz
core-58ef8c188b6bb2ed307f5e825cc7e475c33d0c33.zip
Make spsupp*.dll usable on 64-bit Windows
Build spsupp for both x64 and x86, regardless of target platform. This allows to install the ActiveX component to be used by both 64-bit and 32-bit applications on 64-bit systems (especially IE, which runs both 64-bit and 32-bit processes simultaneously at least on Win10), no matter which LO (32/64) was installed. Move the DLLs from activex feature to ooo, to copy unconditionally. Registration of LO-specific component will be also unconditional; registration of replacement of MSO component will need own feature. This doesn't yet register the component in system: TODO later. Change-Id: Iccf5e73dfae306cb777f844d40611e23c4520a13 Reviewed-on: https://gerrit.libreoffice.org/71925 Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com> Tested-by: Mike Kaganski <mike.kaganski@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 56485ac37f6d..5a34fe080c33 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3581,6 +3581,8 @@ if test "$_os" = "WINNT"; then
AC_MSG_RESULT([not found])
AC_MSG_WARN([Installation set will not contain 64-bit Explorer extensions])
fi
+ else
+ CXX_X64_BINARY=$MSVC_CXX
fi
AC_SUBST(BUILD_X64)